2749-区域内点的个数-JAVA

区域内点的个数

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

X晚上睡不着的时候不喜欢玩手机,也不喜欢打游戏,他喜欢数星星。


Input

 多组输入。

每组先输入一个整数N(N <= 10000),接着输入两个点代表矩形的左下点B(x,y)和右上点T(x,y),然后输入N个(X,Y)代表N颗星星。问有多少颗星星在窗子内部,在窗边上的不计。

Output

 输出一个整数,代表有多少颗星星在窗子内部。


Sample Input

3
0 1
3 4
1 1
2 2
3 3

Sample Output

1

Hint


Source

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			int t = scanner.nextInt();
			int a = scanner.nextInt();
			int b = scanner.nextInt();
			int x = scanner.nextInt();
			int y = scanner.nextInt();
			int court = 0;
			for (int i = 0; i < t; i++) {
				int m = scanner.nextInt();
				int n = scanner.nextInt();
				if (m > a && m < x && n > b && n < y) {
					court++;
				}
			}
			System.out.println(court);
		}
	}
}

 

转载自:https://blog.csdn.net/qq_41436122/article/details/83446560

You may also like...